summaryrefslogtreecommitdiffstats
path: root/slackware64-current/source/xap/mozilla-firefox/mozilla-firefox.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'slackware64-current/source/xap/mozilla-firefox/mozilla-firefox.SlackBuild')
-rwxr-xr-xslackware64-current/source/xap/mozilla-firefox/mozilla-firefox.SlackBuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/slackware64-current/source/xap/mozilla-firefox/mozilla-firefox.SlackBuild b/slackware64-current/source/xap/mozilla-firefox/mozilla-firefox.SlackBuild
index 5810c5732..7db7e6c35 100755
--- a/slackware64-current/source/xap/mozilla-firefox/mozilla-firefox.SlackBuild
+++ b/slackware64-current/source/xap/mozilla-firefox/mozilla-firefox.SlackBuild
@@ -177,13 +177,12 @@ find . \
# Our building options, in a configure-like display ;)
OPTIONS="\
--enable-official-branding \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
- --with-default-mozilla-five-home=/usr/lib${LIBDIRSUFFIX}/firefox-$RELEASEVER \
--with-system-zlib \
--enable-alsa \
--enable-application=browser \
--enable-default-toolkit=cairo-gtk3 \
--enable-startup-notification \
$OPTIMIZE \
@@ -247,21 +246,22 @@ if [ "$PGO" = "yes" ]; then
export MOZ_PGO=1
echo "mk_add_options PROFILE_GEN_SCRIPT='EXTRA_TEST_ARGS=10 \$(MAKE) -C \$(MOZ_OBJDIR) pgo-profile-run'" >> .mozconfig
export DISPLAY=:99
# Launch Xvfb to let the profile scripts run in a X session.
# Ugly note: if the build breaks you may want to do a "killall Xvfb".
Xvfb -nolisten tcp -extension GLX -screen 0 1280x1024x24 $DISPLAY &
- dbus-launch --exit-with-session make -f client.mk build || exit 1
+ dbus-launch --exit-with-session ./mach build || exit 1
kill $! || true
else
# Do a normal build
echo "ac_add_options --disable-tests" >> .mozconfig
- make -f client.mk build || exit 1
+ ./mach build || exit 1
fi
-make -f client.mk install DESTDIR=$PKG || exit 1
+./mach buildsymbols || exit 1
+DESTDIR=$PKG ./mach install || exit 1
# We don't need these (just symlinks anyway):
rm -rf $PKG/usr/lib${LIBDIRSUFFIX}/firefox-devel-$RELEASEVER
# Nor these:
rm -rf $PKG/usr/include