summaryrefslogtreecommitdiffstats
path: root/slackware64-current/source/xap/mozilla-firefox/mozilla-firefox.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'slackware64-current/source/xap/mozilla-firefox/mozilla-firefox.SlackBuild')
-rwxr-xr-xslackware64-current/source/xap/mozilla-firefox/mozilla-firefox.SlackBuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/slackware64-current/source/xap/mozilla-firefox/mozilla-firefox.SlackBuild b/slackware64-current/source/xap/mozilla-firefox/mozilla-firefox.SlackBuild
index 5810c5732..7db7e6c35 100755
--- a/slackware64-current/source/xap/mozilla-firefox/mozilla-firefox.SlackBuild
+++ b/slackware64-current/source/xap/mozilla-firefox/mozilla-firefox.SlackBuild
@@ -180,7 +180,6 @@ OPTIONS="\
180 --enable-official-branding \ 180 --enable-official-branding \
181 --prefix=/usr \ 181 --prefix=/usr \
182 --libdir=/usr/lib${LIBDIRSUFFIX} \ 182 --libdir=/usr/lib${LIBDIRSUFFIX} \
183 --with-default-mozilla-five-home=/usr/lib${LIBDIRSUFFIX}/firefox-$RELEASEVER \
184 --with-system-zlib \ 183 --with-system-zlib \
185 --enable-alsa \ 184 --enable-alsa \
186 --enable-application=browser \ 185 --enable-application=browser \
@@ -250,15 +249,16 @@ if [ "$PGO" = "yes" ]; then
250 # Launch Xvfb to let the profile scripts run in a X session. 249 # Launch Xvfb to let the profile scripts run in a X session.
251 # Ugly note: if the build breaks you may want to do a "killall Xvfb". 250 # Ugly note: if the build breaks you may want to do a "killall Xvfb".
252 Xvfb -nolisten tcp -extension GLX -screen 0 1280x1024x24 $DISPLAY & 251 Xvfb -nolisten tcp -extension GLX -screen 0 1280x1024x24 $DISPLAY &
253 dbus-launch --exit-with-session make -f client.mk build || exit 1 252 dbus-launch --exit-with-session ./mach build || exit 1
254 kill $! || true 253 kill $! || true
255else 254else
256 # Do a normal build 255 # Do a normal build
257 echo "ac_add_options --disable-tests" >> .mozconfig 256 echo "ac_add_options --disable-tests" >> .mozconfig
258 make -f client.mk build || exit 1 257 ./mach build || exit 1
259fi 258fi
260 259
261make -f client.mk install DESTDIR=$PKG || exit 1 260./mach buildsymbols || exit 1
261DESTDIR=$PKG ./mach install || exit 1
262 262
263# We don't need these (just symlinks anyway): 263# We don't need these (just symlinks anyway):
264rm -rf $PKG/usr/lib${LIBDIRSUFFIX}/firefox-devel-$RELEASEVER 264rm -rf $PKG/usr/lib${LIBDIRSUFFIX}/firefox-devel-$RELEASEVER