summaryrefslogtreecommitdiffstats
path: root/sound
AgeCommit message (Collapse)Author
2013-01-12ALSA: hda - Begin HDA_GEN_* event tag from 1Takashi Iwai
... to distinguish from the invalid event type. Signed-off-by: Takashi Iwai <tiwai@suse.de>
2013-01-12ALSA: hda - Increase the max depth of widget connectionsTakashi Iwai
Old codecs like AD1986A tend to have long paths as they were just made to be the way like AC97. The current max depth 5 can be too short for such devices. Signed-off-by: Takashi Iwai <tiwai@suse.de>
2013-01-12ALSA: hda - Avoid access of amp cache element outside mutexTakashi Iwai
The access to a cache array element could be invalid outside the mutex, so copy locally for the later references. Signed-off-by: Takashi Iwai <tiwai@suse.de>
2013-01-12ALSA: hda - Fix wrong dirty check in snd_hda_codec_resume_amp()Takashi Iwai
The dirty entry has to be checked at the beginning in the loop, not in the inner loop for channels. This caused a regression that the right channel isn't properly written. Signed-off-by: Takashi Iwai <tiwai@suse.de>
2013-01-12ALSA: hda - Do sequential writes in snd_hda_gen_init()Takashi Iwai
This would reduce the number of actually executed verbs. Signed-off-by: Takashi Iwai <tiwai@suse.de>
2013-01-12ALSA: hda - Add / fix comments about capture vol/sw controls in hda_generic.cTakashi Iwai
A bit of details won't hurt. Signed-off-by: Takashi Iwai <tiwai@suse.de>
2013-01-12ALSA: hda - Add missing amp cache flush for bound capture vol/sw ctlsTakashi Iwai
The bound capture volume and switch controls use the cached amp updates, but it's missing the flushing at the end. Signed-off-by: Takashi Iwai <tiwai@suse.de>
2013-01-12ALSA: hda - Add snd_hda_codec_flush_*_cache() aliasesTakashi Iwai
It makes easier to understand although these are identical with snd_hda_codec_resume_*() functions. Signed-off-by: Takashi Iwai <tiwai@suse.de>
2013-01-12ALSA: hda - Flush dirty amp caches before writing inv_dmic fixTakashi Iwai
The inverted dmic fix overwrites the right channel amp value, but it would work only when the amp values have been already actually written. Put snd_hda_codec_resume_amp() before the amp write for flushing caches. Signed-off-by: Takashi Iwai <tiwai@suse.de>
2013-01-12ALSA: hda - Check CORB overflowTakashi Iwai
Add an overflow check of CORB in HD-audio controller and codec drivers so that flood of sequential writes would work properly. In the controller side, add a check of CORB read-pointer to make returning -EAGAIN when it's full. Meanwhile in the codec side, when -EAGAIN error is received, it retries the write after flushing the pending verbs (calling get_response() essentially does it). Signed-off-by: Takashi Iwai <tiwai@suse.de>
2013-01-12ALSA: hda - Clear cached_write flag in snd_hda_codec_resume_*()Takashi Iwai
These functions are supposed to be called at finishing the cached sequential writes, so clear the flag properly for lazy developers who often forget details. Signed-off-by: Takashi Iwai <tiwai@suse.de>
2013-01-12ALSA: hda - Clear dirty flag upon cache writeTakashi Iwai
When verbs or amps are actually written to the hardware, we can clear dirty flag so that the later snd_hda_codec_resume_*() calls can skip these verbs / amps. Signed-off-by: Takashi Iwai <tiwai@suse.de>
2013-01-12ALSA: hda - Allow one chance for zero NID in connection listTakashi Iwai
The commit [2e9bf24: ALSA: hda_codec: Check for invalid zero connections] trims the whole connection list when an invalid value is reported by the hardware. But some codecs (at least AD1986A) may give a zero NID in the middle of the connection list, so dropping the whole list isn't good for such cases. In this patch, as a workaround, allow a single zero NID in the read connection list. If it hits zero twice, it's handled as an error, so that we can avoid "too many connections" errors. Signed-off-by: Takashi Iwai <tiwai@suse.de>
2013-01-12ALSA: hda - Use "Capture Source" for single sourcesTakashi Iwai
In general we prefer "Capture Source" to "Input Source". The latter was chosen in many places just because "Capture Source" label doesn't work well with the current alsa-lib mixer abstraction when multiple instances are present. But when we know that there is a single input-source element, we can safely choose "Capture Source" label. Signed-off-by: Takashi Iwai <tiwai@suse.de>
2013-01-12ALSA: hda - Use generic parser codes for Realtek driverTakashi Iwai
The next migration step is to use the common code in generic driver for Realtek driver. This is no drastic change and there should be no real functional changes, as the generic parser code comes from Realtek driver originally. As Realtek driver requires the generic parser code, it needs a reverse-selection of CONFIG_SND_HDA_GENERIC kconfig. Signed-off-by: Takashi Iwai <tiwai@suse.de>
2013-01-12ALSA: hda - Export standard jack event handlers for generic parserTakashi Iwai
These handlers are supposed to be called externally from the codec drivers once when they need to handle own jack events. Signed-off-by: Takashi Iwai <tiwai@suse.de>
2013-01-12ALSA: hda - Fix NULL dereference in snd_hda_gen_build_controls()Takashi Iwai
When no controls are assigned in the parser (e.g. no analog path), spec->kctls.list is still NULL. We need to check it before passing to snd_hda_add_new_ctls(). Signed-off-by: Takashi Iwai <tiwai@suse.de>
2013-01-12ALSA: hda - Move the call of snd_hda_parse_pin_defcfg() from ↵Takashi Iwai
snd_hda_gen_parse_auto_config() In some cases, we want to manipulate the auto_pin_cfg table before passing to snd_hda_gen_parse_auto_config() (e.g. Realtek SSID check code fiddles with the headphone pin). Also passing ignore_pins just for snd_hda_parse_pin_defcfg() isn't good. In this patch, snd_hda_gen_parse_auto_config() is changed to receive the auto_pin_cfg table to be parsed. The passed auto_pin_cfg table must have been initialized (typically by calling snd_hda_gen_parse_auto_config()) beforehand by the caller. Also together with this change, spec->parse_flags is also removed. Since this was referred only at the place calling snd_hda_parse_pin_defcfg(), no longer needed to be kept in spec. Signed-off-by: Takashi Iwai <tiwai@suse.de>
2013-01-12ALSA: hda - Export snd_hda_gen_add_kctl()Takashi Iwai
It may be used in other codec drivers, so let it free. Signed-off-by: Takashi Iwai <tiwai@suse.de>
2013-01-12ALSA: hda - Add EAPD control to generic parserTakashi Iwai
Enable EAPD in output path initializations automatically unless the new flag spec->own_eapd_ctl is set. Signed-off-by: Takashi Iwai <tiwai@suse.de>
2013-01-12ALSA: hda - Merge Realtek parser code to generic parserTakashi Iwai
Finally the whole generic parser code in Realtek driver is moved into hda_generic.c so that it can be used for generic codec driver. The old dumb generic driver is replaced. Yay. The future plan is to adapt this generic parser for other codecs, i.e. the codec driver calls the exported functions in generic driver but adds some codec-specific fixes and setups. As of this commit, the complete driver code is still duplicated in Realtek codec driver. The big code reduction will come from now on. Signed-off-by: Takashi Iwai <tiwai@suse.de>
2013-01-12ALSA: hda/realtek - Remove redundant argument from alc_mux_select()Takashi Iwai
The argument "force" is always false in the recent code. Signed-off-by: Takashi Iwai <tiwai@suse.de>
2013-01-12ALSA: hda - More generic auto-mic switching for Realtek codecsTakashi Iwai
This patch extends the capability of the auto-mic feature. Instead of limiting the automatic input-source selection only to the mics (internal, external and dock mics), allow it for generic inputs, e.g. switching between the rear line-in and the front mic. The logic is to check the attribute and location of input pins, and enable the automatic selection feature only if all such pins are in different locations (e.g. internal, front, rear, etc) and line-in or mic pins. That is, if multiple input pins are assigned to a single location, the feature isn't enabled because we don't know the priority. (You may wonder why this restriction doesn't exist for the headphone automute. The reason is that the output case is different from the input: the input source is an exclusive selection while the output can be multiplexed.) Note that, for avoiding regressions, the line-in auto switching feature isn't activated as default. It has to be set explicitly via spec->line_in_auto_switch flag in a fixup code. Signed-off-by: Takashi Iwai <tiwai@suse.de>
2013-01-12ALSA: hda - Rearrange INPUT_PIN_ATTR_*Takashi Iwai
Put INPUT_PIN_ATTR_FRONT after INPUT_PIN_ATTR_REAR, and define INPUT_PIN_ATTR_LAST to point to the last element. This is a preliminary work for cleaning up Realtek auto-mic parser. In the auto-mic implementation, the front panel is preferred over the rear panel. By arranging the attr definitions like in this commit, we can simply use sort() for figuring out the priority order. Signed-off-by: Takashi Iwai <tiwai@suse.de>
2013-01-12ALSA: hda/realtek - Fix split stereo dmic codeTakashi Iwai
The previous commit passed an utterly wrong value for checking the split inv dmic pin. This patch fixes it and also tries to remove inv_dmic_split_idx field. Signed-off-by: Takashi Iwai <tiwai@suse.de>
2013-01-12ALSA: hda - Move fixup code into struct hda_codecTakashi Iwai
Since the fixup code is used commonly, it's worth to move it to the common place, struct hda_codec, instead of keeping in hda_gen_spec. Signed-off-by: Takashi Iwai <tiwai@suse.de>
2013-01-12ALSA: hda/realtek - Add conexant-style inverted dmic handlingTakashi Iwai
To make the parser more generic, a few codes to handle the inverted stereo dmic in a way Conexant parser does is added in this patch. The caller should set spec->inv_dmic_split flag appropriately. Signed-off-by: Takashi Iwai <tiwai@suse.de>
2013-01-12ALSA: hda/realtek - Allow multiple individual capture volume/switch controlsTakashi Iwai
So far we create only "Capture Volume" and "Capture Switch" controls for binding all possible amps, but we'd prefer creating individual capture volume and switch controls per input in some cases (e.g. conexant parser does it). Add a new flag, spec->multi_cap_vol, to follow that policy. Signed-off-by: Takashi Iwai <tiwai@suse.de>
2013-01-12ALSA: hda/realtek - Allow passing name=NULL to alc_kcontrol_new()Takashi Iwai
This prevents stupid typos. Signed-off-by: Takashi Iwai <tiwai@suse.de>
2013-01-12ALSA: hda/realtek - Merge a few split functionsTakashi Iwai
Merge a few functions that have been split due to historical reasons to single functions. Splitting too much (and placing too far away) actually worsens the readability. Signed-off-by: Takashi Iwai <tiwai@suse.de>
2013-01-12ALSA: hda/realtek - Assign Master mixer when possibleTakashi Iwai
There are a few more cases where we can assign "Master" mixer element safely, e.g. when a single DAC is used in the whole output paths. Also, when vmaster hook is present, avoid "Master" but assign "PCM" instead. Otherwise vmaster hook won't work properly. Signed-off-by: Takashi Iwai <tiwai@suse.de>
2013-01-12ALSA: hda/realtek - Handle vmaster hook in the parser sideTakashi Iwai
... so that the fixup just needs to set the hook function in FIXUP_ACT_PROBE. This will make easier to port for other codecs, too. Signed-off-by: Takashi Iwai <tiwai@suse.de>
2013-01-12ALSA: hda/realtek - Remove unused fields and macro definitionsTakashi Iwai
Also arranged alc_spec definitions to optimize bit fields. Use a bit field for spec->need_dac_fix, too. Signed-off-by: Takashi Iwai <tiwai@suse.de>
2013-01-12ALSA: hda/realtek - Drop auto_mic_valid_imux flagTakashi Iwai
This flag is superfluous now and it's always as same as spec->auto_mic. Let's drop. Signed-off-by: Takashi Iwai <tiwai@suse.de>
2013-01-12ALSA: hda/realtek - Allow different pins for shared hp/mic vref checkTakashi Iwai
Add a new field to indicate the possible pin NID for alternative vref setup for the shared hp/mic. Although 0x18 is valid for all Realtek codecs, it'll be different on other vendor's codecs. Also, drop the sanity check in update_shared_mic_hp() since the reference pin is set explicitly in the caller side. Signed-off-by: Takashi Iwai <tiwai@suse.de>
2013-01-12ALSA: hda/realtek - Parse digital input pathTakashi Iwai
This was the last forgotten path. Now it's parsed via the same path parser. Signed-off-by: Takashi Iwai <tiwai@suse.de>
2013-01-12ALSA: hda/realtek - Rename add_new_out_path() with add_new_nid_path()Takashi Iwai
Make the function more generic for both input and output directions, and returns the assigned path pointer. The argument order is changed to follow the standard (from, to) way. Now this new function is used for analog input and loopback path parser codes, too. Signed-off-by: Takashi Iwai <tiwai@suse.de>
2013-01-12ALSA: hda/realtek - Remove superfluous input amp initTakashi Iwai
The amps will be initialized via activate_path(), thus it's superfluous to set in alc_auto_init_analog_input(). Signed-off-by: Takashi Iwai <tiwai@suse.de>
2013-01-12ALSA: hda/realtek - Clean up some spec fieldsTakashi Iwai
Remove some fields from struct alc_spec, and clean up the usage. Namely, - spec->input_mux becomes a single element, private_imux[] is removed - spec->adc_nids becomes an array by itself, and private_adc_nids[] gets removed, too Signed-off-by: Takashi Iwai <tiwai@suse.de>
2013-01-12ALSA: hda/realtek - Make input path parser more genericTakashi Iwai
Now we reached to the final big piece of parser rewrite: the input paths. While the old parser code assumes the more-or-less direct and similar connections from input pin to ADC, the new code handles the complete input paths. The capture source is switched by simple calls of activate_path() function. The parsing of capture volume and capture switches is, however, not fully generalized. It assumes that amps are available in the vicinity of ADCs (in three depth). This isn't perfect but it should cover all codecs I know of. Also, this commit removes some NID mapping of capture-related controls temporarily for simplicity. It'll be restored in later commits. Signed-off-by: Takashi Iwai <tiwai@suse.de>
2013-01-12ALSA: hda/realtek - Don't change connection at path deactivationTakashi Iwai
The widget connection selection must be changed only when the path is enabled. Signed-off-by: Takashi Iwai <tiwai@suse.de>
2013-01-12ALSA: hda/realtek - Initialize loopback paths properlyTakashi Iwai
Now we have a complete list of loopback paths, thus we can initialize the paths more completely based on it, instead of assuming a direct connection from pin to mixer. Signed-off-by: Takashi Iwai <tiwai@suse.de>
2013-01-12ALSA: hda/realtek - Add boost volumes to path listTakashi Iwai
Don't forget to take boost volumes into account in the managed path list. Since it's an additional volume, we need to extend the ctls[] array. Signed-off-by: Takashi Iwai <tiwai@suse.de>
2013-01-12ALSA: hda/realtek - Add missing initialization of multi-io routesTakashi Iwai
The paths used for multi-io haven't been initialized properly, so far. It's usually no big matter because the pins are set to input as default, but it's still cleaner to initialize the paths properly. Now with the path active/inactive check, we can do it easily. Signed-off-by: Takashi Iwai <tiwai@suse.de>
2013-01-12ALSA: hda/realtek - Fix the initialization of pin amp-inTakashi Iwai
The pin widget has only a single amp value for the input even if it has multiple "sources". Handle the situation in activate_path(). Signed-off-by: Takashi Iwai <tiwai@suse.de>
2013-01-12ALSA: hda/realtek - Rename get_out_path() to get_nid_path()Takashi Iwai
The function can be used not only for output paths but generically. Also swap the argument order. Signed-off-by: Takashi Iwai <tiwai@suse.de>
2013-01-12ALSA: hda/realtek - Use path-based parser for digital outputsTakashi Iwai
Similar like analog output paths, use the path list for parsing and initializing digital outputs as well. Signed-off-by: Takashi Iwai <tiwai@suse.de>
2013-01-12ALSA: hda/realtek - Consolidate to a single path listTakashi Iwai
We don't have to keep three individual path lists for input, output and loopback. Signed-off-by: Takashi Iwai <tiwai@suse.de>
2013-01-12ALSA: hda/realtek - Consolidate is_reachable_path()Takashi Iwai
alc_auto_is_dac_reachable() can be replaced fully with is_reachable_path(). The only difference is the order of arguments. Signed-off-by: Takashi Iwai <tiwai@suse.de>
2013-01-12ALSA: hda/realtek - Add path active flagTakashi Iwai
... and rewrite the initialization of output paths as a generic function that is applicable for both i/o directions. The new flag, active, is introduced to each nid_path entry. This indicates whether the given path is active, and it's used for checking whether a certain widget can be turned off or changed when a path is no longer used or newly enabled. It's still used only in the output paths. More wider adaption for input and loopback paths will be achieved in the later patch. Signed-off-by: Takashi Iwai <tiwai@suse.de>