summaryrefslogtreecommitdiffstats
path: root/machines/jormungand/hardware-configuration.nix
diff options
context:
space:
mode:
authorDominique Martinet @ jormungand <asmadeus@codewreck.org>2020-05-08 10:54:36 +0200
committerDominique Martinet @ jormungand <asmadeus@codewreck.org>2020-05-08 10:54:36 +0200
commit7056660a12e3d0bf24e032d4a51245e1bd606d51 (patch)
treed40a9e0a74f650a485cb640e807066354aa2832c /machines/jormungand/hardware-configuration.nix
parente0bd9d4e088750cbfed608cba761abdbfaab5772 (diff)
refactoring: add common modules, move machine-specific stuff to machines/$HOSTNAME...
Diffstat (limited to 'machines/jormungand/hardware-configuration.nix')
-rw-r--r--machines/jormungand/hardware-configuration.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/machines/jormungand/hardware-configuration.nix b/machines/jormungand/hardware-configuration.nix
new file mode 100644
index 0000000..d169d0b
--- /dev/null
+++ b/machines/jormungand/hardware-configuration.nix
@@ -0,0 +1,30 @@
+# Do not modify this file! It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations. Please make changes
+# to /etc/nixos/configuration.nix instead.
+{ config, lib, pkgs, modulesPath, ... }:
+
+{
+ imports =
+ [ (modulesPath + "/installer/scan/not-detected.nix")
+ ];
+
+ boot.initrd.availableKernelModules = [ "uhci_hcd" "ehci_pci" "ahci" "sd_mod" ];
+ boot.initrd.kernelModules = [ ];
+ boot.kernelModules = [ ];
+ boot.extraModulePackages = [ ];
+
+ fileSystems."/" =
+ { device = "/dev/disk/by-uuid/c7964da7-b631-4528-8005-98b265233160";
+ fsType = "ext4";
+ };
+ fileSystems."/boot" =
+ { device = "/dev/disk/by-uuid/b9911970-b6a3-49e1-a6df-1372b9022962";
+ fsType = "ext4";
+ };
+
+ swapDevices =
+ [ { device = "/dev/disk/by-uuid/abf1930c-4e44-4d0c-baa5-138d4216c882"; }
+ ];
+
+ #powerManagement.cpuFreqGovernor = lib.mkDefault "ondemand";
+}