summaryrefslogtreecommitdiffstats
path: root/machines/jormungand/cryptpad.nix
diff options
context:
space:
mode:
Diffstat (limited to 'machines/jormungand/cryptpad.nix')
-rw-r--r--machines/jormungand/cryptpad.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/machines/jormungand/cryptpad.nix b/machines/jormungand/cryptpad.nix
index 5d408d5..32ae0a1 100644
--- a/machines/jormungand/cryptpad.nix
+++ b/machines/jormungand/cryptpad.nix
@@ -1,6 +1,13 @@
{ config, pkgs, ... }:
{
+ # Node 12 is deprecated and flagged insecure... allow for a bit until
+ # https://github.com/rvl/bower2nix/pull/22 or https://github.com/xwiki-labs/cryptpad/issues/295 moves
+
+ nixpkgs.config.permittedInsecurePackages = [
+ "nodejs-12.22.12"
+ ];
+
services.cryptpad = {
enable = true;
configFile = ./cryptpad.config.js;