summaryrefslogtreecommitdiffstats
path: root/profiles/miniflux.nix
diff options
context:
space:
mode:
Diffstat (limited to 'profiles/miniflux.nix')
-rw-r--r--profiles/miniflux.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/profiles/miniflux.nix b/profiles/miniflux.nix
index 49d567c..1fe8961 100644
--- a/profiles/miniflux.nix
+++ b/profiles/miniflux.nix
@@ -8,7 +8,11 @@
config = {
POLLING_SCHEDULER = "entry_frequency";
CLEANUP_ARCHIVE_READ_DAYS = "30";
- LISTEN_ADDR = "localhost:8081";
+ LISTEN_ADDR = "[::1]:8081";
+ WORKER_POOL_SIZE = "2";
+ POLLING_FREQUENCY = "180";
+ BATCH_SIZE = "3";
+ SCHEDULER_ENTRY_FREQUENCY_MAX_INTERVAL = "10080"; # 7*24*60 = 7d
};
adminCredentialsFile = "/etc/nixos/secrets/miniflux";
};
@@ -23,6 +27,7 @@
"/etc/hosts"
];
DynamicUser = lib.mkForce false;
+ User = "miniflux";
# prestart inits the db, only needed the first time and conflicts with confinement
ExecStartPre = lib.mkForce "";
};