summaryrefslogtreecommitdiffstats
path: root/profiles/otp.nix
diff options
context:
space:
mode:
Diffstat (limited to 'profiles/otp.nix')
-rw-r--r--profiles/otp.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/profiles/otp.nix b/profiles/otp.nix
new file mode 100644
index 0000000..a8207a4
--- /dev/null
+++ b/profiles/otp.nix
@@ -0,0 +1,11 @@
+{ config, pkgs, ... }:
+
+{
+ # use `gen-oath-safe username [hotp|totp]`
+ # scan code & add last line to /etc/users.oath
+ environment.systemPackages = with pkgs; [
+ gen-oath-safe
+ ];
+
+ security.pam.oath.enable = true;
+}