summaryrefslogtreecommitdiffstats
path: root/package/luarocks/luarocks.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/luarocks/luarocks.mk')
-rw-r--r--package/luarocks/luarocks.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/luarocks/luarocks.mk b/package/luarocks/luarocks.mk
index f5c1a3a94..30be6e635 100644
--- a/package/luarocks/luarocks.mk
+++ b/package/luarocks/luarocks.mk
@@ -14,17 +14,17 @@ HOST_LUAROCKS_DEPENDENCIES = host-luainterpreter
LUAROCKS_CONFIG_DIR = $(HOST_DIR)/usr/etc/luarocks
LUAROCKS_CONFIG_FILE = $(LUAROCKS_CONFIG_DIR)/config-$(LUAINTERPRETER_ABIVER).lua
-HOST_LUAROCKS_CONF_OPT = \
+HOST_LUAROCKS_CONF_OPTS = \
--prefix=$(HOST_DIR)/usr \
--sysconfdir=$(LUAROCKS_CONFIG_DIR) \
--with-lua=$(HOST_DIR)/usr
ifeq ($(BR2_PACKAGE_LUAJIT),y)
-HOST_LUAROCKS_CONF_OPT += --lua-suffix=jit
+HOST_LUAROCKS_CONF_OPTS += --lua-suffix=jit
endif
define HOST_LUAROCKS_CONFIGURE_CMDS
- cd $(@D) && ./configure $(HOST_LUAROCKS_CONF_OPT)
+ cd $(@D) && ./configure $(HOST_LUAROCKS_CONF_OPTS)
endef
define HOST_LUAROCKS_INSTALL_CMDS