summaryrefslogtreecommitdiffstats
path: root/package/x11vnc/x11vnc.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/x11vnc/x11vnc.mk')
-rw-r--r--package/x11vnc/x11vnc.mk20
1 files changed, 10 insertions, 10 deletions
diff --git a/package/x11vnc/x11vnc.mk b/package/x11vnc/x11vnc.mk
index bd0f530ab..57d6f8dba 100644
--- a/package/x11vnc/x11vnc.mk
+++ b/package/x11vnc/x11vnc.mk
@@ -8,63 +8,63 @@ X11VNC_VERSION = 0.9.13
X11VNC_SITE = http://downloads.sourceforge.net/project/libvncserver/x11vnc/$(X11VNC_VERSION)
# sdl support is not used in x11vnc, but host include / library search paths
# leak in if host has sdl-config
-X11VNC_CONF_OPT = --without-sdl
+X11VNC_CONF_OPTS = --without-sdl
X11VNC_DEPENDENCIES = xlib_libXt xlib_libXext xlib_libXtst
X11VNC_LICENSE = GPLv2+
X11VNC_LICENSE_FILES = COPYING
ifneq ($(BR2_INET_IPV6),y)
# configure option only used for libvncserver
-X11VNC_CONF_OPT += --without-ipv6
+X11VNC_CONF_OPTS += --without-ipv6
X11VNC_CONF_ENV += CFLAGS='$(TARGET_CFLAGS) -DX11VNC_IPV6=0'
endif
ifeq ($(BR2_PACKAGE_AVAHI_DAEMON)$(BR2_PACKAGE_DBUS),yy)
X11VNC_DEPENDENCIES += avahi dbus
else
-X11VNC_CONF_OPT += --without-avahi
+X11VNC_CONF_OPTS += --without-avahi
endif
ifeq ($(BR2_PACKAGE_JPEG),y)
X11VNC_DEPENDENCIES += jpeg
else
-X11VNC_CONF_OPT += --without-jpeg
+X11VNC_CONF_OPTS += --without-jpeg
endif
ifeq ($(BR2_PACKAGE_OPENSSL),y)
X11VNC_DEPENDENCIES += openssl
else
-X11VNC_CONF_OPT += --without-ssl --without-crypto
+X11VNC_CONF_OPTS += --without-ssl --without-crypto
endif
ifeq ($(BR2_PACKAGE_XLIB_LIBXINERAMA),y)
X11VNC_DEPENDENCIES += xlib_libXinerama
else
-X11VNC_CONF_OPT += --without-xinerama
+X11VNC_CONF_OPTS += --without-xinerama
endif
ifeq ($(BR2_PACKAGE_XLIB_LIBXRANDR),y)
X11VNC_DEPENDENCIES += xlib_libXrandr
else
-X11VNC_CONF_OPT += --without-xrandr
+X11VNC_CONF_OPTS += --without-xrandr
endif
ifeq ($(BR2_PACKAGE_XLIB_LIBXFIXES),y)
X11VNC_DEPENDENCIES += xlib_libXfixes
else
-X11VNC_CONF_OPT += --without-xfixes
+X11VNC_CONF_OPTS += --without-xfixes
endif
ifeq ($(BR2_PACKAGE_XLIB_LIBXDAMAGE),y)
X11VNC_DEPENDENCIES += xlib_libXdamage
else
-X11VNC_CONF_OPT += --without-xdamage
+X11VNC_CONF_OPTS += --without-xdamage
endif
ifeq ($(BR2_PACKAGE_ZLIB),y)
X11VNC_DEPENDENCIES += zlib
else
-X11VNC_CONF_OPT += --without-zlib
+X11VNC_CONF_OPTS += --without-zlib
endif